Connect to an old Erlang node

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Connect to an old Erlang node

Frank Muller
Hi guys

Can I disable this behaviour when connecting to an old node with no support
for UTF8 atoms?

(client@riot)1> 

=ERROR REPORT==== 17-Nov-2017::00:32:12 ===

** server@riot: Connection attempt from node server@dev rejected since it cannot handle ["UTF8_ATOMS"].**


I’m not using UTF8 at all and just want to be able to connect.


Is there a flag to disable this?


Thank you.

/Frank


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Connect to an old Erlang node

Lukas Larsson-8


On Thu, Dec 13, 2018 at 8:07 AM Frank Muller <[hidden email]> wrote:
Hi guys

Can I disable this behaviour when connecting to an old node with no support
for UTF8 atoms?

(client@riot)1> 

=ERROR REPORT==== 17-Nov-2017::00:32:12 ===

** server@riot: Connection attempt from node server@dev rejected since it cannot handle ["UTF8_ATOMS"].**


I’m not using UTF8 at all and just want to be able to connect.


Is there a flag to disable this?


No. The support to talk using latin1 atoms has been removed from the VM on newer versions of Erlang.
 


Thank you.

/Frank

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Connect to an old Erlang node

Frank Muller
Hi Lukas

How about thedistribution protocol version compatability with the +R option:

Will it help on my case?

Best
/Frank



On Thu, Dec 13, 2018 at 8:07 AM Frank Muller <[hidden email]> wrote:
Hi guys

Can I disable this behaviour when connecting to an old node with no support
for UTF8 atoms?

(client@riot)1> 

=ERROR REPORT==== 17-Nov-2017::00:32:12 ===

** server@riot: Connection attempt from node server@dev rejected since it cannot handle ["UTF8_ATOMS"].**


I’m not using UTF8 at all and just want to be able to connect.


Is there a flag to disable this?


No. The support to talk using latin1 atoms has been removed from the VM on newer versions of Erlang.
 


Thank you.

/Frank

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Connect to an old Erlang node

Lukas Larsson-8


On Tue, Dec 18, 2018 at 4:04 PM Frank Muller <[hidden email]> wrote:
Hi Lukas

How about thedistribution protocol version compatability with the +R option:

Will it help on my case?

No, it will not.


That option currently does not currently do anything at all.
 

Best
/Frank



On Thu, Dec 13, 2018 at 8:07 AM Frank Muller <[hidden email]> wrote:
Hi guys

Can I disable this behaviour when connecting to an old node with no support
for UTF8 atoms?

(client@riot)1> 

=ERROR REPORT==== 17-Nov-2017::00:32:12 ===

** server@riot: Connection attempt from node server@dev rejected since it cannot handle ["UTF8_ATOMS"].**


I’m not using UTF8 at all and just want to be able to connect.


Is there a flag to disable this?


No. The support to talk using latin1 atoms has been removed from the VM on newer versions of Erlang.
 


Thank you.

/Frank

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Connect to an old Erlang node

Frank Muller
Ok, thanks for the info Lukas

/Frank



On Tue, Dec 18, 2018 at 4:04 PM Frank Muller <[hidden email]> wrote:
Hi Lukas

How about thedistribution protocol version compatability with the +R option:

Will it help on my case?

No, it will not.


That option currently does not currently do anything at all.
 

Best
/Frank



On Thu, Dec 13, 2018 at 8:07 AM Frank Muller <[hidden email]> wrote:
Hi guys

Can I disable this behaviour when connecting to an old node with no support
for UTF8 atoms?

(client@riot)1> 

=ERROR REPORT==== 17-Nov-2017::00:32:12 ===

** server@riot: Connection attempt from node server@dev rejected since it cannot handle ["UTF8_ATOMS"].**


I’m not using UTF8 at all and just want to be able to connect.


Is there a flag to disable this?


No. The support to talk using latin1 atoms has been removed from the VM on newer versions of Erlang.
 


Thank you.

/Frank

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions