Eleveldb / Snappy on macOS 10.13

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Eleveldb / Snappy on macOS 10.13

Marc Worrell
Hi,

I am trying to compile eleveldb on macOS 10.13 and running into compile errors.
Anybody got a fork or an idea which magic CXXFLAGS might do the trick?

Thanks!

Marc


gmake[1]: Entering directory '/Users/marc/tmp/eleveldb/eleveldb/c_src/snappy-1.0.4'
/bin/sh ./libtool --tag=CXX   --mode=compile c++ -DHAVE_CONFIG_H -I.     -Wall -O3 -fPIC -mmacosx-version-min=10.8 -MT snappy.lo -MD -MP -MF .deps/snappy.Tpo -c -o snappy.lo snappy.cc
libtool: compile:  c++ -DHAVE_CONFIG_H -I. -Wall -O3 -fPIC -mmacosx-version-min=10.8 -MT snappy.lo -MD -MP -MF .deps/snappy.Tpo -c snappy.cc  -fno-common -DPIC -o snappy.o
warning: include path for stdlibc++ headers not found; pass '-std=libc++' on the command line to use the libc++ standard library instead [-Wstdlibcxx-not-found]
In file included from snappy.cc:29:
./snappy.h:43:10: fatal error: 'string' file not found
#include <string>
         ^~~~~~~~
1 warning and 1 error generated.
Makefile:417: recipe for target 'snappy.lo' failed




_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Eleveldb / Snappy on macOS 10.13

Max Lapshin-2
1) try `xcode-select --install

2) try clang++  

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Eleveldb / Snappy on macOS 10.13

Marc Worrell
Hi Max,

I have “fixed” the issue by completely removing my current Xcode install and re-installing it from scratch.
(Including all the optional extra packages for command line an what-not).

Apparently something in my Xcode install was broken, and it came up with this less thank helpful error.

Cheers,

Marc


> On 9 Dec 2018, at 18:49, Max Lapshin <[hidden email]> wrote:
>
> 1) try `xcode-select --install
>
> 2) try clang++  

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions