Erlang and SOAP

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Erlang and SOAP

Erik Reitsma (RY/ETM)-2
Hi all,

I am trying to get SOAP to work with Erlang. I have found the idx-esoap package, but it requires xmerl 0.11, which then needs to be patched.

I could not get esoap to work with xmerl 0.15 (the current version), at least the test gave an error and no result. I tried to apply the patch manually, but that did not work either.

Does anybody know whether idx-esoap should work with xmerl 0.15? Or does anyody have xmerl 0.11 somewhere? Or an xmerl version that works with idx-esoap 0.1.0 (latest version as far as I know)? Any other suggestions?

*Erik.


Reply | Threaded
Open this post in threaded view
|

Erlang and SOAP

Mickael Remond-2
Erik Reitsma (ELN) (Erik.Reitsma) wrote:
> Hi all,
>
> I am trying to get SOAP to work with Erlang. I have found the idx-esoap package, but it requires xmerl 0.11, which then needs to be patched.
>
> I could not get esoap to work with xmerl 0.15 (the current version), at least the test gave an error and no result. I tried to apply the patch manually, but that did not work either.
>
> Does anybody know whether idx-esoap should work with xmerl 0.15? Or does anyody have xmerl 0.11 somewhere? Or an xmerl version that works with idx-esoap 0.1.0 (latest version as far as I know)? Any other suggestions?

>From what I remember, the patch is very small (Only one line and can be
easily applied to xmerl 0.15). The patch only add a document node, that
we found missing in the current implementation.

I can send you a ready made prepatched version of xmerl 0.15 if you want
to.

I am currently rewriting the whole thing from scratch as a module for
inets. The new implementation is not yet finished. I still working on
it. Sean is also eagerly waiting for it ;-) So I will do my best to
package it quickly (My job is taking my days, night and week-end...)

Cheers,

--
Micka?l R?mond