Issue with wxDatePickerCtrl in wxerlang

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Issue with wxDatePickerCtrl in wxerlang

Gattu shiva krishna

Hi all,

        In my application there is a requirement to use the wxDatePickerCtrl wxwidget. When I am using this widget I am unable to get the date which is selected from the datePicker widget.

For example:

If I select 17th July 2017 in the datePicker Widget, the correct date is displayed in the text area. But when I click anywhere out of the area, it gets updated back to the current date with some garbage value such as Monday1517October201717. Is there any solution or work-around for this problem?


Regards,

Gattu shivakrishna


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Issue with wxDatePickerCtrl in wxerlang

zxq9-2
On 2017年07月15日 土曜日 14:21:05 Gattu shiva krishna wrote:

> Hi all,
>
>          In my application there is a requirement to use the
> wxDatePickerCtrl wxwidget. When I am using this widget I am unable to
> get the date which is selected from the datePicker widget.
>
> For example:
>
> If I select 17th July 2017 in the datePicker Widget, the correct date is
> displayed in the text area. But when I click anywhere out of the area,
> it gets updated back to the current date with some garbage value such as
> *Monday1517October201717***. Is there any solution or work-around for
> this problem?

It sounds like the value is being updated by some on-click or on-focus action. Are you listening/connected to those anywhere else in your code? If you are, then make sure you're doing getValue/1 on it, and don't call setValue/2 or especially setRange/3 afterward (it is already set, so that would only be a chance to mix something up).

I've never seen this problem before, but this is the kind of thing I would check first.

-Craig
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Loading...