Makefile not generated for erlang folder

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Makefile not generated for erlang folder

Chris Hicks-4
Hello folks,

I'm using the otp_src_20.0.tar.gz downloaded from Erlang.com and following the instructions found here: http://erlang.org/doc/installation_guide/INSTALL.html

However, when I attempt to run `make` everything works fine until right after the hipe application. The error I get is as follows:

make[2]: Leaving directory `<root folder>/build/private/src/lib/hipe'
make[2]: Entering directory `<root folder>/build/private/src/lib/erlang'
make[2]: *** No rule to make target `opt'.  Stop.

When looking at the erlang folder the Makefile has not been generated. The build process is being handled by a custom build system and is kicked off by a custom build script, which really just makes sure the required libraries are linked so that they can be found when running `./configure` and `make`

The relevant parts of the script are as follows, minus some long paths for readability:

export ERL_TOP=$WRITABLE_SRC_DIR
SSL_CONFIG=" --with-ssl-zlib=<zlib path here> --with-ssl=<ssl path here>"
tar -xzf otp_src_20.0.tar.gz --strip-components 1 -C "$WRITABLE_SRC_DIR"
./configure "--prefix=$INSTALL_DIR" $SSL_CONFIG
make -j "$CPU_COUNT"

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Makefile not generated for erlang folder

Taavi Talvik-2
Any chance, that you are on Mac OS with case insensitive file system?

best regards,
taavi

On 22 Dec 2017, at 19:32, Chris Hicks <[hidden email]> wrote:

Hello folks,

I'm using the otp_src_20.0.tar.gz downloaded from Erlang.com and following the instructions found here: http://erlang.org/doc/installation_guide/INSTALL.html

However, when I attempt to run `make` everything works fine until right after the hipe application. The error I get is as follows:

make[2]: Leaving directory `<root folder>/build/private/src/lib/hipe'
make[2]: Entering directory `<root folder>/build/private/src/lib/erlang'
make[2]: *** No rule to make target `opt'.  Stop.

When looking at the erlang folder the Makefile has not been generated. The build process is being handled by a custom build system and is kicked off by a custom build script, which really just makes sure the required libraries are linked so that they can be found when running `./configure` and `make`

The relevant parts of the script are as follows, minus some long paths for readability:

export ERL_TOP=$WRITABLE_SRC_DIR
SSL_CONFIG=" --with-ssl-zlib=<zlib path here> --with-ssl=<ssl path here>"
tar -xzf otp_src_20.0.tar.gz --strip-components 1 -C "$WRITABLE_SRC_DIR"
./configure "--prefix=$INSTALL_DIR" $SSL_CONFIG
make -j "$CPU_COUNT"
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions



_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Makefile not generated for erlang folder

Chris Hicks-4
Nope, taking place on RHEL 5.3 according to "cat /etc/*-release"

There are some company specific things done to the release but I'm not certain what those are. 

On Dec 22, 2017 2:05 PM, <[hidden email]> wrote:
Any chance, that you are on Mac OS with case insensitive file system?

best regards,
taavi

On 22 Dec 2017, at 19:32, Chris Hicks <[hidden email]> wrote:

Hello folks,

I'm using the otp_src_20.0.tar.gz downloaded from Erlang.com and following the instructions found here: http://erlang.org/doc/installation_guide/INSTALL.html

However, when I attempt to run `make` everything works fine until right after the hipe application. The error I get is as follows:

make[2]: Leaving directory `<root folder>/build/private/src/lib/hipe'
make[2]: Entering directory `<root folder>/build/private/src/lib/erlang'
make[2]: *** No rule to make target `opt'.  Stop.

When looking at the erlang folder the Makefile has not been generated. The build process is being handled by a custom build system and is kicked off by a custom build script, which really just makes sure the required libraries are linked so that they can be found when running `./configure` and `make`

The relevant parts of the script are as follows, minus some long paths for readability:

export ERL_TOP=$WRITABLE_SRC_DIR
SSL_CONFIG=" --with-ssl-zlib=<zlib path here> --with-ssl=<ssl path here>"
tar -xzf otp_src_20.0.tar.gz --strip-components 1 -C "$WRITABLE_SRC_DIR"
./configure "--prefix=$INSTALL_DIR" $SSL_CONFIG
make -j "$CPU_COUNT"
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions



_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions