Missing init:get_args() function ?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing init:get_args() function ?

PAILLEAU Eric
$> erl -sname titi -config toto

Erlang R14B02 (erts-5.8.3) [source] [smp:2:2] [rq:2] [async-threads:0]
[hipe] [kernel-poll:false]

Eshell V5.8.3  (abort with ^G)
1> init:get_args().
** exception error: undefined function init:get_args/0

while

2> init:get_plain_arguments().
[]

Looks like init:get_args() does not exists while still in last
documentation.

Did I miss something in doc, or is it a bug ?

Regards.
_______________________________________________
erlang-bugs mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-bugs
Reply | Threaded
Open this post in threaded view
|

Re: Missing init:get_args() function ?

PAILLEAU Eric
Hello,

no answer to this ?

Should init:get_args/0 not any more used ?

Regards.

Le 31/03/2011 21:53, PAILLEAU Eric a écrit :

> $> erl -sname titi -config toto
>
> Erlang R14B02 (erts-5.8.3) [source] [smp:2:2] [rq:2] [async-threads:0]
> [hipe] [kernel-poll:false]
>
> Eshell V5.8.3  (abort with ^G)
> 1> init:get_args().
> ** exception error: undefined function init:get_args/0
>
> while
>
> 2> init:get_plain_arguments().
> []
>
> Looks like init:get_args() does not exists while still in last
> documentation.
>
> Did I miss something in doc, or is it a bug ?
>
> Regards.
> _______________________________________________
> erlang-bugs mailing list
> [hidden email]
> http://erlang.org/mailman/listinfo/erlang-bugs
>

_______________________________________________
erlang-bugs mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-bugs
Reply | Threaded
Open this post in threaded view
|

Re: Missing init:get_args() function ?

Bengt Kleberg
Greetings,

init:get_args/0 is in the documentation, without restrictions. Therefore
this is a bug. Either in the code or the documentation.


ebngt

On Thu, 2011-04-07 at 22:32 +0200, PAILLEAU Eric wrote:

> Hello,
>
> no answer to this ?
>
> Should init:get_args/0 not any more used ?
>
> Regards.
>
> Le 31/03/2011 21:53, PAILLEAU Eric a écrit :
> > $> erl -sname titi -config toto
> >
> > Erlang R14B02 (erts-5.8.3) [source] [smp:2:2] [rq:2] [async-threads:0]
> > [hipe] [kernel-poll:false]
> >
> > Eshell V5.8.3  (abort with ^G)
> > 1> init:get_args().
> > ** exception error: undefined function init:get_args/0
> >
> > while
> >
> > 2> init:get_plain_arguments().
> > []
> >
> > Looks like init:get_args() does not exists while still in last
> > documentation.
> >
> > Did I miss something in doc, or is it a bug ?
> >
> > Regards.
> > _______________________________________________
> > erlang-bugs mailing list
> > [hidden email]
> > http://erlang.org/mailman/listinfo/erlang-bugs
> >
>
> _______________________________________________
> erlang-bugs mailing list
> [hidden email]
> http://erlang.org/mailman/listinfo/erlang-bugs

_______________________________________________
erlang-bugs mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-bugs
pan
Reply | Threaded
Open this post in threaded view
|

Re: Missing init:get_args() function ?

pan
Hi!

init:get_args got deprecated in R9C (!) and was removed in R12. Why it
wasn't removed from documentation is a mystery yet unsolved...

So - confirmed documentation bug, it will be corrected in the next
release.

Thank's for reporting!

Cheers,
/Patrik

On Fri, 8 Apr 2011, Bengt Kleberg wrote:

> Greetings,
>
> init:get_args/0 is in the documentation, without restrictions. Therefore
> this is a bug. Either in the code or the documentation.
>
>
> ebngt
>
> On Thu, 2011-04-07 at 22:32 +0200, PAILLEAU Eric wrote:
>> Hello,
>>
>> no answer to this ?
>>
>> Should init:get_args/0 not any more used ?
>>
>> Regards.
>>
>> Le 31/03/2011 21:53, PAILLEAU Eric a écrit :
>>> $> erl -sname titi -config toto
>>>
>>> Erlang R14B02 (erts-5.8.3) [source] [smp:2:2] [rq:2] [async-threads:0]
>>> [hipe] [kernel-poll:false]
>>>
>>> Eshell V5.8.3  (abort with ^G)
>>> 1> init:get_args().
>>> ** exception error: undefined function init:get_args/0
>>>
>>> while
>>>
>>> 2> init:get_plain_arguments().
>>> []
>>>
>>> Looks like init:get_args() does not exists while still in last
>>> documentation.
>>>
>>> Did I miss something in doc, or is it a bug ?
>>>
>>> Regards.
>>> _______________________________________________
>>> erlang-bugs mailing list
>>> [hidden email]
>>> http://erlang.org/mailman/listinfo/erlang-bugs
>>>
>>
>> _______________________________________________
>> erlang-bugs mailing list
>> [hidden email]
>> http://erlang.org/mailman/listinfo/erlang-bugs
>
> _______________________________________________
> erlang-bugs mailing list
> [hidden email]
> http://erlang.org/mailman/listinfo/erlang-bugs
>
_______________________________________________
erlang-bugs mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-bugs