Patch package OTP 20.3.1 released

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Patch package OTP 20.3.1 released

Ingela Anderton Andin-4
Patch Package:           OTP 20.3.1
Git Tag:                 OTP-20.3.1
Date:                    2018-03-16
Trouble Report Id:       OTP-14981
Seq num:                
System:                  OTP
Release:                 20
Application:             ssl-8.2.5
Predecessor:             OTP 20.3

 Check out the git tag OTP-20.3.1, and build a full OTP system
 including documentation. Apply one or more applications from this
 build as patches to your installation using the 'otp_patch_apply'
 tool. For information on install requirements, see descriptions for
 each application version below.

 ---------------------------------------------------------------------
 --- ssl-8.2.5 -------------------------------------------------------
 ---------------------------------------------------------------------

 Note! The ssl-8.2.5 application can *not* be applied independently of
       other applications on an arbitrary OTP 20 installation.

       On a full OTP 20 installation, also the following runtime
       dependencies have to be satisfied:
       -- crypto-4.2 (first satisfied in OTP 20.2)
       -- public_key-1.5 (first satisfied in OTP 20.1)


 --- Fixed Bugs and Malfunctions ---

  OTP-14981    Application(s): ssl

               Fix filter function to not incorrectly exclude AEAD
               cipher suites


 Full runtime dependencies of ssl-8.2.5: crypto-4.2, erts-7.0,
 inets-5.10.7, kernel-3.0, public_key-1.5, stdlib-3.2


 ---------------------------------------------------------------------
 ---------------------------------------------------------------------
 ---------------------------------------------------------------------

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Patch package OTP 20.3.1 released

Tristan Sloughter-4
Does this not include the gen_statem patch?

On Fri, Mar 16, 2018, at 3:35 AM, Ingela Anderton Andin wrote:

> Patch Package:           OTP 20.3.1
> Git Tag:                 OTP-20.3.1
> Date:                    2018-03-16
> Trouble Report Id:       OTP-14981
> Seq num:                
> System:                  OTP
> Release:                 20
> Application:             ssl-8.2.5
> Predecessor:             OTP 20.3
>
>  Check out the git tag OTP-20.3.1, and build a full OTP system
>  including documentation. Apply one or more applications from this
>  build as patches to your installation using the 'otp_patch_apply'
>  tool. For information on install requirements, see descriptions for
>  each application version below.
>
>  ---------------------------------------------------------------------
>  --- ssl-8.2.5 -------------------------------------------------------
>  ---------------------------------------------------------------------
>
>  Note! The ssl-8.2.5 application can *not* be applied independently of
>        other applications on an arbitrary OTP 20 installation.
>
>        On a full OTP 20 installation, also the following runtime
>        dependencies have to be satisfied:
>        -- crypto-4.2 (first satisfied in OTP 20.2)
>        -- public_key-1.5 (first satisfied in OTP 20.1)
>
>
>  --- Fixed Bugs and Malfunctions ---
>
>   OTP-14981    Application(s): ssl
>
>                Fix filter function to not incorrectly exclude AEAD
>                cipher suites
>
>
>  Full runtime dependencies of ssl-8.2.5: crypto-4.2, erts-7.0,
>  inets-5.10.7, kernel-3.0, public_key-1.5, stdlib-3.2
>
>
>  ---------------------------------------------------------------------
>  ---------------------------------------------------------------------
>  ---------------------------------------------------------------------
>
> _______________________________________________
> erlang-questions mailing list
> [hidden email]
> http://erlang.org/mailman/listinfo/erlang-questions
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: Patch package OTP 20.3.1 released

Raimo Niskanen-2
On Mon, Mar 19, 2018 at 04:01:18PM -0700, Tristan Sloughter wrote:
> Does this not include the gen_statem patch?

Nope.  I am working on that one - did not manage to get all administration
stuff done in time from when I was in San Francisco.  With a bit of luck
the patched gen_statem can be released tomorrow CET.

/ Raimo


>
> On Fri, Mar 16, 2018, at 3:35 AM, Ingela Anderton Andin wrote:
> > Patch Package:           OTP 20.3.1
> > Git Tag:                 OTP-20.3.1
> > Date:                    2018-03-16
> > Trouble Report Id:       OTP-14981
> > Seq num:                
> > System:                  OTP
> > Release:                 20
> > Application:             ssl-8.2.5
> > Predecessor:             OTP 20.3
> >
> >  Check out the git tag OTP-20.3.1, and build a full OTP system
> >  including documentation. Apply one or more applications from this
> >  build as patches to your installation using the 'otp_patch_apply'
> >  tool. For information on install requirements, see descriptions for
> >  each application version below.
> >
> >  ---------------------------------------------------------------------
> >  --- ssl-8.2.5 -------------------------------------------------------
> >  ---------------------------------------------------------------------
> >
> >  Note! The ssl-8.2.5 application can *not* be applied independently of
> >        other applications on an arbitrary OTP 20 installation.
> >
> >        On a full OTP 20 installation, also the following runtime
> >        dependencies have to be satisfied:
> >        -- crypto-4.2 (first satisfied in OTP 20.2)
> >        -- public_key-1.5 (first satisfied in OTP 20.1)
> >
> >
> >  --- Fixed Bugs and Malfunctions ---
> >
> >   OTP-14981    Application(s): ssl
> >
> >                Fix filter function to not incorrectly exclude AEAD
> >                cipher suites
> >
> >
> >  Full runtime dependencies of ssl-8.2.5: crypto-4.2, erts-7.0,
> >  inets-5.10.7, kernel-3.0, public_key-1.5, stdlib-3.2
> >
> >
> >  ---------------------------------------------------------------------
> >  ---------------------------------------------------------------------
> >  ---------------------------------------------------------------------
> >
> > _______________________________________________
> > erlang-questions mailing list
> > [hidden email]
> > http://erlang.org/mailman/listinfo/erlang-questions
> _______________________________________________
> erlang-questions mailing list
> [hidden email]
> http://erlang.org/mailman/listinfo/erlang-questions

--

/ Raimo Niskanen, Erlang/OTP, Ericsson AB
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions