Please test snapshots of the coming R9C

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Please test snapshots of the coming R9C

Mikael Pettersson
On Thu, 10 Jul 2003 10:47:49 +0200 (MEST), Mikael Pettersson wrote:

>On Thu, 10 Jul 2003 09:25:33 +0300, Per Bergqvist wrote:
>>Hipe doesn't build properly with the 07-09 snapshot.
>>
>>erlc -W  -bbeam  +debug_info  -o../ebin hipe_tagscheme.erl
>>/home/perber/build/otp_src_P9C_2003-07-09/lib/hipe/rtl/hipe_tagscheme.
>>erl:695: undefined macro ''P_OFF_HEAP_OVERHEAD''
>>/home/perber/build/otp_src_P9C_2003-07-09/lib/hipe/rtl/hipe_tagscheme.
>>erl:37: function finalize_bin/4 undefined
>>make[1]: *** [../ebin/hipe_tagscheme.beam] Error 1
>
>It seems you configured for shared heap; it builds Ok
>in the default private heap configuration.

My mistake -- make completed the build but I forgot that make
doesn't halt on errors under lib/ on Linux/RH9 for some reason,
and your error did indeed occur in lib/hipe/.

The problem is that somehow shared-heap gets enabled by default,
but the HiPE compiler currently breaks in that configuration.
I'll have a look at the configuration problem later today.

/Mikael


Reply | Threaded
Open this post in threaded view
|

Please test snapshots of the coming R9C

Björn Gustavsson-3
Please check the latest snapshot. The problem has probably
been fixed.

/Bjorn

Mikael Pettersson <mikpe> writes:

> On Thu, 10 Jul 2003 10:47:49 +0200 (MEST), Mikael Pettersson wrote:
> >On Thu, 10 Jul 2003 09:25:33 +0300, Per Bergqvist wrote:
> >>Hipe doesn't build properly with the 07-09 snapshot.
> >>
> >>erlc -W  -bbeam  +debug_info  -o../ebin hipe_tagscheme.erl
> >>/home/perber/build/otp_src_P9C_2003-07-09/lib/hipe/rtl/hipe_tagscheme.
> >>erl:695: undefined macro ''P_OFF_HEAP_OVERHEAD''
> >>/home/perber/build/otp_src_P9C_2003-07-09/lib/hipe/rtl/hipe_tagscheme.
> >>erl:37: function finalize_bin/4 undefined
> >>make[1]: *** [../ebin/hipe_tagscheme.beam] Error 1
> >
> >It seems you configured for shared heap; it builds Ok
> >in the default private heap configuration.
>
> My mistake -- make completed the build but I forgot that make
> doesn't halt on errors under lib/ on Linux/RH9 for some reason,
> and your error did indeed occur in lib/hipe/.
>
> The problem is that somehow shared-heap gets enabled by default,
> but the HiPE compiler currently breaks in that configuration.
> I'll have a look at the configuration problem later today.
>
> /Mikael
>

--
Bj?rn Gustavsson            Ericsson Utvecklings AB
bjorn      ?T2/UAB/F/P
                            BOX 1505
+46 8 727 56 87    125 25 ?lvsj?


Reply | Threaded
Open this post in threaded view
|

Please test snapshots of the coming R9C

Rickard Green-3
In reply to this post by Mikael Pettersson
This is fixed in the next snapshot.

Both a separate heap emulator and a shared heap emulator are now built.
The shared heap emulator is started by passing erl the -shared command
line argument. If hipe has been enabled, the shared heap emulator will
not be able to run native compiled code though. (This since the hipe
application use hipe_mkliterals compiled for the separate heap emulator.)

Regards,
Rickard Green, Erlang/OTP

Mikael Pettersson wrote:

> On Thu, 10 Jul 2003 10:47:49 +0200 (MEST), Mikael Pettersson wrote:
>
>>On Thu, 10 Jul 2003 09:25:33 +0300, Per Bergqvist wrote:
>>
>>>Hipe doesn't build properly with the 07-09 snapshot.
>>>
>>>erlc -W  -bbeam  +debug_info  -o../ebin hipe_tagscheme.erl
>>>/home/perber/build/otp_src_P9C_2003-07-09/lib/hipe/rtl/hipe_tagscheme.
>>>erl:695: undefined macro ''P_OFF_HEAP_OVERHEAD''
>>>/home/perber/build/otp_src_P9C_2003-07-09/lib/hipe/rtl/hipe_tagscheme.
>>>erl:37: function finalize_bin/4 undefined
>>>make[1]: *** [../ebin/hipe_tagscheme.beam] Error 1
>>
>>It seems you configured for shared heap; it builds Ok
>>in the default private heap configuration.
>
>
> My mistake -- make completed the build but I forgot that make
> doesn't halt on errors under lib/ on Linux/RH9 for some reason,
> and your error did indeed occur in lib/hipe/.
>
> The problem is that somehow shared-heap gets enabled by default,
> but the HiPE compiler currently breaks in that configuration.
> I'll have a look at the configuration problem later today.
>
> /Mikael
>