Quantcast

Working with erl_boot_server

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Working with erl_boot_server

Kevin A. Smith-2
I've been poking all day at a problem I've run into with  
erl_boot_server. I've got a set of applications and a boot file which  
work fine when I use the boot file locally like so:

erl -sname foo -pz appfoo/ebin -pz appbar/ebin -boot appboot

When I try to use the boot file with erl_boot_server the node crashes  
with what looks like an inability to load the application module for  
one of the apps:

=CRASH REPORT==== 5-Aug-2008::16:21:19 ===
   crasher:
     pid: <0.79.0>
     registered_name: []
     exception exit: {bad_return,
                      {{foo_app,start,
                        [normal,[{config_file,"/etc/baz/appfoo.cfg"}]]},
                       {'EXIT',
                        {undef,
                         [{foo_app,start,
                           [normal,
                            [{config_file,"/etc/baz/appfoo.cfg"}]]},
                          {application_master,start_it_old,4}]}}}}

I've made sure that the node running the boot server has the same code  
paths as the node I used to test the application locally. I'm pretty  
sure I've got something configured wrong with code paths or maybe app  
files but I haven't been able to figure it out yet.

Any suggestions on things to investigate (app files, pathing, etc) or  
pointers to docs on how to use erl_boot_server (besides Joel's blog  
posts) would be great.

Thanks,
Kevin
_______________________________________________
erlang-questions mailing list
[hidden email]
http://www.erlang.org/mailman/listinfo/erlang-questions
Loading...