ct_run -vts crashes

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ct_run -vts crashes

Frans Schneider-2
Running ct_run -vts gives a crash dump. What could be wrong?

$ ct_run -vts
Erlang/OTP 20 [erts-9.2] [source] [64-bit] [smp:2:2] [ds:2:2:10]
[async-threads:10] [kernel-poll:false]

Starting webtool...
{"init terminating in
do_boot",{{badmatch,{error,{error,error_dir}}},[{ct_webtool,script_start,1,[{file,"ct_webtool.erl"},{line,148}]},{init,start_em,1,[]},{init,do_boot,3,[]}]}}
init terminating in do_boot
({{badmatch,{error,{error,error_dir}}},[{ct_webtool,script_start,1,[{_},{_}]},{init,start_em,1,[]},{init,do_boot,3,[]}]})

Crash dump is being written to: erl_crash.dump...done

Frans
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: ct_run -vts crashes

Dmitry Kolesnikov-2
Hello,

{error, error_dir}

You config points to non existed directory. Check out config. 

- Dmitry


On 29 Mar 2018, at 16.03, Frans Schneider <[hidden email]> wrote:

Running ct_run -vts gives a crash dump. What could be wrong?

$ ct_run -vts
Erlang/OTP 20 [erts-9.2] [source] [64-bit] [smp:2:2] [ds:2:2:10] [async-threads:10] [kernel-poll:false]

Starting webtool...
{"init terminating in do_boot",{{badmatch,{error,{error,error_dir}}},[{ct_webtool,script_start,1,[{file,"ct_webtool.erl"},{line,148}]},{init,start_em,1,[]},{init,do_boot,3,[]}]}}
init terminating in do_boot ({{badmatch,{error,{error,error_dir}}},[{ct_webtool,script_start,1,[{_},{_}]},{init,start_em,1,[]},{init,do_boot,3,[]}]})

Crash dump is being written to: erl_crash.dump...done

Frans
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: ct_run -vts crashes

Frans Schneider-2
Which config file would that be? 

Op 29 mrt. 2018 om 15:08 heeft Dmitry Kolesnikov <[hidden email]> het volgende geschreven:

Hello,

{error, error_dir}

You config points to non existed directory. Check out config. 

- Dmitry


On 29 Mar 2018, at 16.03, Frans Schneider <[hidden email]> wrote:

Running ct_run -vts gives a crash dump. What could be wrong?

$ ct_run -vts
Erlang/OTP 20 [erts-9.2] [source] [64-bit] [smp:2:2] [ds:2:2:10] [async-threads:10] [kernel-poll:false]

Starting webtool...
{"init terminating in do_boot",{{badmatch,{error,{error,error_dir}}},[{ct_webtool,script_start,1,[{file,"ct_webtool.erl"},{line,148}]},{init,start_em,1,[]},{init,do_boot,3,[]}]}}
init terminating in do_boot ({{badmatch,{error,{error,error_dir}}},[{ct_webtool,script_start,1,[{_},{_}]},{init,start_em,1,[]},{init,do_boot,3,[]}]})

Crash dump is being written to: erl_crash.dump...done

Frans
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions