digraph fails to add vertex

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

digraph fails to add vertex

Karlo Kuna
hello 
in my little program i am doing successive calls to digraph:add_vertex/2
and then my program deterministically fails with: 
 ** exception error: {badrecord,digraph}
     in function  digraph:do_add_vertex/2 (digraph.erl, line 378)
     in call from sets:fold_bucket/3 (sets.erl, line 310)
     in call from sets:fold_seg/4 (sets.erl, line 306) 
     in call from sets:fold_segs/4 (sets.erl, line 302)

however i cannot locate any problems, and the failing call is not in any way special 

thanks



_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: digraph fails to add vertex

Karlo Kuna
i'm sorry for previous mail 
i have found my mistake 

i just wish that error would be something like: {badrecord, {expects, digraph}}

On Fri, May 25, 2018 at 10:43 AM, Karlo Kuna <[hidden email]> wrote:
hello 
in my little program i am doing successive calls to digraph:add_vertex/2
and then my program deterministically fails with: 
 ** exception error: {badrecord,digraph}
     in function  digraph:do_add_vertex/2 (digraph.erl, line 378)
     in call from sets:fold_bucket/3 (sets.erl, line 310)
     in call from sets:fold_seg/4 (sets.erl, line 306) 
     in call from sets:fold_segs/4 (sets.erl, line 302)

however i cannot locate any problems, and the failing call is not in any way special 

thanks




_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions