net_adm:ping/1 fails with Erlang/OTP 20

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

net_adm:ping/1 fails with Erlang/OTP 20

Martin Koroudjiev

 

Hello,

 

I am using jInterface 1.5.3.1 for an Erlang-Java communication. It all used to work fine prior to upgrading to Erlang/OTP 20. Now net_adm:ping/1 fails with the following message:

 

[error] ** 'dilbert@LORI-PC': Connection attempt to node 'jnode@LORI-PC' aborted since it cannot handle ["UTF8_ATOMS"].**

 

Any ideas what can it be?

 

Thanks,

Martin


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: net_adm:ping/1 fails with Erlang/OTP 20

Dmitry Kolesnikov-2
As far, I re-call OTP 20 made changes to external term format.
It looks like you need to build and use jinterface from OTP 20.
The maven version  might not be up to date.

- Dmitry


> On Jul 6, 2017, at 5:00 PM, Martin Dimitrov <[hidden email]> wrote:
>
>  
> Hello,
>  
> I am using jInterface 1.5.3.1 for an Erlang-Java communication. It all used to work fine prior to upgrading to Erlang/OTP 20. Now net_adm:ping/1 fails with the following message:
>  
> [error] ** 'dilbert@LORI-PC': Connection attempt to node 'jnode@LORI-PC' aborted since it cannot handle ["UTF8_ATOMS"].**
>  
> Any ideas what can it be?
>  
> Thanks,
> Martin
> _______________________________________________
> erlang-questions mailing list
> [hidden email]
> http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: net_adm:ping/1 fails with Erlang/OTP 20

Eric des Courtis-3
In reply to this post by Martin Koroudjiev
I suspect it's because it cannot handle UTF-8 atoms (vs Latin-1 atoms). Are you using the jinterface that is shipped with Erlang/OTP 20?

On Thu, Jul 6, 2017 at 10:00 AM, Martin Dimitrov <[hidden email]> wrote:

 

Hello,

 

I am using jInterface 1.5.3.1 for an Erlang-Java communication. It all used to work fine prior to upgrading to Erlang/OTP 20. Now net_adm:ping/1 fails with the following message:

 

[error] ** 'dilbert@LORI-PC': Connection attempt to node 'jnode@LORI-PC' aborted since it cannot handle ["UTF8_ATOMS"].**

 

Any ideas what can it be?

 

Thanks,

Martin


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions



_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: net_adm:ping/1 fails with Erlang/OTP 20

Martin Koroudjiev

No, I am using the latest maven version. I will try what you’ve suggested and will let you know. Thanks, guys.

 

From: [hidden email]
Sent: Thursday, July 6, 2017 5:03 PM
To: [hidden email]
Cc: [hidden email]
Subject: Re: [erlang-questions] net_adm:ping/1 fails with Erlang/OTP 20

 

I suspect it's because it cannot handle UTF-8 atoms (vs Latin-1 atoms). Are you using the jinterface that is shipped with Erlang/OTP 20?

 

On Thu, Jul 6, 2017 at 10:00 AM, Martin Dimitrov <[hidden email]> wrote:

 

Hello,

 

I am using jInterface 1.5.3.1 for an Erlang-Java communication. It all used to work fine prior to upgrading to Erlang/OTP 20. Now net_adm:ping/1 fails with the following message:

 

[error] ** 'dilbert@LORI-PC': Connection attempt to node 'jnode@LORI-PC' aborted since it cannot handle ["UTF8_ATOMS"].**

 

Any ideas what can it be?

 

Thanks,

Martin


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

 

 


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: net_adm:ping/1 fails with Erlang/OTP 20

Martin Koroudjiev

Hello again,

 

With 1.8 version I don’t see this problem. Thanks.

 

Regards,

Martin

 

From: [hidden email]
Sent: Thursday, July 6, 2017 5:05 PM
To: [hidden email]
Cc: [hidden email]
Subject: RE: [erlang-questions] net_adm:ping/1 fails with Erlang/OTP 20

 

No, I am using the latest maven version. I will try what you’ve suggested and will let you know. Thanks, guys.

 

From: [hidden email]
Sent: Thursday, July 6, 2017 5:03 PM
To: [hidden email]
Cc: [hidden email]
Subject: Re: [erlang-questions] net_adm:ping/1 fails with Erlang/OTP 20

 

I suspect it's because it cannot handle UTF-8 atoms (vs Latin-1 atoms). Are you using the jinterface that is shipped with Erlang/OTP 20?

 

On Thu, Jul 6, 2017 at 10:00 AM, Martin Dimitrov <[hidden email]> wrote:

 

Hello,

 

I am using jInterface 1.5.3.1 for an Erlang-Java communication. It all used to work fine prior to upgrading to Erlang/OTP 20. Now net_adm:ping/1 fails with the following message:

 

[error] ** 'dilbert@LORI-PC': Connection attempt to node 'jnode@LORI-PC' aborted since it cannot handle ["UTF8_ATOMS"].**

 

Any ideas what can it be?

 

Thanks,

Martin


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

 

 

 


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Loading...