rdbms

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

rdbms

Fredrik Linder-2
Hi Ulf Wiger

Do you, or anyone else for that matter, plan to upgrade rdbms to work with mnesia 4.1.4 ?

Regards
/Fredrik


Reply | Threaded
Open this post in threaded view
|

rdbms

Ulf Wiger (AL/EAB)
On Mon, 22 Mar 2004 15:20:48 +0100, Fredrik Linder
<fredrik.linder> wrote:

> Hi Ulf Wiger
>
> Do you, or anyone else for that matter, plan to upgrade rdbms to work
> with mnesia 4.1.4 ?

I will confess that I haven't tested rdbms on mnesia-4.1.4...

...or, rather, I _have_ used rdbms with mnesia-4.1.4 but didn't
encounter any problems. But then again I'm running rdbms-1.5, and
the latest version publicly available seems to be 1.3.

I will try to find some time to update jungerl.

Those of you who actually use RDBMS are welcome to drop me a line
describing what you use it for. I've had no user reports on rdbms
since its release in January '99 (and few, if any, bug reports,
which has led me to believe that there _are_ no users of it.)

/Uffe
--
Ulf Wiger, Senior System Architect
EAB/UPD/S

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.



Reply | Threaded
Open this post in threaded view
|

rdbms

Ulf Wiger (AL/EAB)
On Mon, 22 Mar 2004 15:44:59 +0100, Ulf Wiger <ulf.wiger>
wrote:

> On Mon, 22 Mar 2004 15:20:48 +0100, Fredrik Linder
> <fredrik.linder> wrote:
>
>> Hi Ulf Wiger
>>
>> Do you, or anyone else for that matter, plan to upgrade rdbms to work
>> with mnesia 4.1.4 ?
>
> I will confess that I haven't tested rdbms on mnesia-4.1.4...
>
> ...or, rather, I _have_ used rdbms with mnesia-4.1.4 but didn't
> encounter any problems. But then again I'm running rdbms-1.5, and
> the latest version publicly available seems to be 1.3.
>
> I will try to find some time to update jungerl.


Jungerl now updated with rdbms-1.5. I also added an updated manual
in PDF format.

Extract from the README file:

"Changes since 1.3 (1.4 was an experiment never released.)

- A bug that could lead to endless loops during cascading delete has
   been fixed.

- New options: 'add_references', 'drop_references' make it easier to
   plug in new dependencies when new tables are created.

- Exported functions, create_table/2 and delete_table/1 allow for more
   integrated handling of rdbms options. delete_table/1 will clean up
   dangling referential integrity options automatically."


Please let me know if there are any problems.

/Uffe
--
Ulf Wiger, Senior System Architect
EAB/UPD/S

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.