ubuntu1804 install erlang with source: No usable OpenSSL found

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

ubuntu1804 install erlang with source: No usable OpenSSL found

Monk Boy
Hi all:

When I configure the otp_src, I got this:

```
memacs@memacs-beam:~/下载/otp_src_19.3$ ./configure  --prefix=/home/memacs/opt/erlang/1903

............................
checking whether MAP_FIXED is declared... yes
checking whether MAP_NORESERVE is declared... yes
configure: WARNING: Security feature -fPIE will be disabled for HiPE
configure: Floating point exceptions disabled by default on Linux
checking whether to redefine FD_SETSIZE... no
configure: Enable exec_alloc for hipe code allocation
checking for working poll()... yes
checking whether epoll is level triggered... yes
checking whether kernel poll support should be enabled... yes; epoll
checking whether putenv() stores a copy of the key-value pair... no
checking for ld... gcc
checking for compiler flags for loadable drivers... -g -O2 -I/home/memacs/下载/otp_src_19.3/erts/x86_64-unknown-linux-gnu   -fno-tree-copyrename  -D_GNU_SOURCE -fPIC
checking for linker for loadable drivers... gcc
checking for linker flags for loadable drivers... -shared -Wl,-Bsymbolic
checking for 'runtime library path' linker flag... -Wl,-R
checking for a compiler that handles jumptables... gcc
checking for static ZLib to be used by SSL in standard locations... no
checking for OpenSSL >= 0.9.7 in standard locations... found; but not usable
configure: WARNING: No (usable) OpenSSL found, skipping ssl, ssh and crypto applications
checking for kstat_open in -lkstat... (cached) no
checking for kvm_open in -lkvm... no
checking for javac.sh... no
checking for javac... javac
checking for JDK version 1.6... no
configure: WARNING: Could not find any usable java compiler, will skip: jinterface
checking for c++... c++
checking for log2... yes
configure: creating ./config.status
config.status: creating emulator/x86_64-unknown-linux-gnu/Makefile
config.status: creating epmd/src/x86_64-unknown-linux-gnu/Makefile
config.status: creating etc/common/x86_64-unknown-linux-gnu/Makefile
config.status: creating include/internal/x86_64-unknown-linux-gnu/ethread.mk
config.status: creating include/internal/x86_64-unknown-linux-gnu/erts_internal.mk
config.status: creating lib_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating Makefile
config.status: creating ../make/x86_64-unknown-linux-gnu/otp.mk
config.status: creating ../make/x86_64-unknown-linux-gnu/otp_ded.mk
config.status: creating ../make/make_emakefile
config.status: creating ../lib/ic/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/os_mon/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/crypto/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/orber/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/runtime_tools/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/tools/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating x86_64-unknown-linux-gnu/config.h
config.status: x86_64-unknown-linux-gnu/config.h is unchanged
config.status: creating include/internal/x86_64-unknown-linux-gnu/ethread_header_config.h
config.status: include/internal/x86_64-unknown-linux-gnu/ethread_header_config.h is unchanged
config.status: creating include/x86_64-unknown-linux-gnu/erl_int_sizes_config.h
config.status: include/x86_64-unknown-linux-gnu/erl_int_sizes_config.h is unchanged
*********************************************************************
**********************  APPLICATIONS DISABLED  **********************
*********************************************************************

crypto         : No usable OpenSSL found
jinterface     : No Java compiler found
ssh            : No usable OpenSSL found
ssl            : No usable OpenSSL found

*********************************************************************
*********************************************************************
**********************  APPLICATIONS INFORMATION  *******************
*********************************************************************

wx             : wxWidgets not found, wx will NOT be usable

*********************************************************************
memacs@memacs-beam:~/下载/otp_src_19.3$ openssl version
OpenSSL 1.1.0g  2 Nov 2017
memacs@memacs-beam:~/下载/otp_src_19.3$ uname -a
Linux memacs-beam 4.18.0-20-generic #21~18.04.1-Ubuntu SMP Wed May 8 08:43:37 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
memacs@memacs-beam:~/下载/otp_src_19.3$ sudo apt-get install libssl-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
libssl-dev 已经是最新版 (1.1.0g-2ubuntu4.3)。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
memacs@memacs-beam:~/下载/otp_src_19.3$
```

The openssl is installed, but why it is unusable?

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu1804 install erlang with source: No usable OpenSSL found

Guilherme Andrade
Hello Monk Boy,

On Mon, 27 May 2019 at 12:51, Monk Boy <[hidden email]> wrote:
The openssl is installed, but why it is unusable?

Erlang/OTP 19 is not compatible with OpenSSL 1.1.x, unfortunately.

Related ticket in kerl repo:
https://github.com/kerl/kerl/issues/226

--
Guilherme

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu1804 install erlang with source: No usable OpenSSL found

Dmitry Klionsky-2
In reply to this post by Monk Boy

Hi,

Had the same issue recently on Ubuntu 18.10. OTP 19.3 wants OpelSSL 1.0.x.

Make/install OpenSSL:

curl https://www.openssl.org/source/openssl-1.0.2r.tar.gz | tar xfz - && cd openssl-1.0.2r && ./config --prefix=/usr/local/openssl-1.0.2r -fpic && make && sudo make install && cd .. && rm -rf openssl-1.0.2r creates=/usr/local/openssl-1.0.2r

Reconfigure/build OTP 19.3 with the flag

--with-ssl=/usr/local/openssl-1.0.2r


On 5/27/19 2:51 PM, Monk Boy wrote:
Hi all:

When I configure the otp_src, I got this:

```
memacs@memacs-beam:~/下载/otp_src_19.3$ ./configure  --prefix=/home/memacs/opt/erlang/1903

............................
checking whether MAP_FIXED is declared... yes
checking whether MAP_NORESERVE is declared... yes
configure: WARNING: Security feature -fPIE will be disabled for HiPE
configure: Floating point exceptions disabled by default on Linux
checking whether to redefine FD_SETSIZE... no
configure: Enable exec_alloc for hipe code allocation
checking for working poll()... yes
checking whether epoll is level triggered... yes
checking whether kernel poll support should be enabled... yes; epoll
checking whether putenv() stores a copy of the key-value pair... no
checking for ld... gcc
checking for compiler flags for loadable drivers... -g -O2 -I/home/memacs/下载/otp_src_19.3/erts/x86_64-unknown-linux-gnu   -fno-tree-copyrename  -D_GNU_SOURCE -fPIC
checking for linker for loadable drivers... gcc
checking for linker flags for loadable drivers... -shared -Wl,-Bsymbolic
checking for 'runtime library path' linker flag... -Wl,-R
checking for a compiler that handles jumptables... gcc
checking for static ZLib to be used by SSL in standard locations... no
checking for OpenSSL >= 0.9.7 in standard locations... found; but not usable
configure: WARNING: No (usable) OpenSSL found, skipping ssl, ssh and crypto applications
checking for kstat_open in -lkstat... (cached) no
checking for kvm_open in -lkvm... no
checking for javac.sh... no
checking for javac... javac
checking for JDK version 1.6... no
configure: WARNING: Could not find any usable java compiler, will skip: jinterface
checking for c++... c++
checking for log2... yes
configure: creating ./config.status
config.status: creating emulator/x86_64-unknown-linux-gnu/Makefile
config.status: creating epmd/src/x86_64-unknown-linux-gnu/Makefile
config.status: creating etc/common/x86_64-unknown-linux-gnu/Makefile
config.status: creating include/internal/x86_64-unknown-linux-gnu/ethread.mk
config.status: creating include/internal/x86_64-unknown-linux-gnu/erts_internal.mk
config.status: creating lib_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating Makefile
config.status: creating ../make/x86_64-unknown-linux-gnu/otp.mk
config.status: creating ../make/x86_64-unknown-linux-gnu/otp_ded.mk
config.status: creating ../make/make_emakefile
config.status: creating ../lib/ic/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/os_mon/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/crypto/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/orber/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/runtime_tools/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating ../lib/tools/c_src/x86_64-unknown-linux-gnu/Makefile
config.status: creating x86_64-unknown-linux-gnu/config.h
config.status: x86_64-unknown-linux-gnu/config.h is unchanged
config.status: creating include/internal/x86_64-unknown-linux-gnu/ethread_header_config.h
config.status: include/internal/x86_64-unknown-linux-gnu/ethread_header_config.h is unchanged
config.status: creating include/x86_64-unknown-linux-gnu/erl_int_sizes_config.h
config.status: include/x86_64-unknown-linux-gnu/erl_int_sizes_config.h is unchanged
*********************************************************************
**********************  APPLICATIONS DISABLED  **********************
*********************************************************************

crypto         : No usable OpenSSL found
jinterface     : No Java compiler found
ssh            : No usable OpenSSL found
ssl            : No usable OpenSSL found

*********************************************************************
*********************************************************************
**********************  APPLICATIONS INFORMATION  *******************
*********************************************************************

wx             : wxWidgets not found, wx will NOT be usable

*********************************************************************
memacs@memacs-beam:~/下载/otp_src_19.3$ openssl version
OpenSSL 1.1.0g  2 Nov 2017
memacs@memacs-beam:~/下载/otp_src_19.3$ uname -a
Linux memacs-beam 4.18.0-20-generic #21~18.04.1-Ubuntu SMP Wed May 8 08:43:37 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
memacs@memacs-beam:~/下载/otp_src_19.3$ sudo apt-get install libssl-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
libssl-dev 已经是最新版 (1.1.0g-2ubuntu4.3)。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
memacs@memacs-beam:~/下载/otp_src_19.3$
```

The openssl is installed, but why it is unusable?

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu1804 install erlang with source: No usable OpenSSL found

Monk Boy
In reply to this post by Guilherme Andrade
Ok, thanks.  I will update openssl to solve it.

Guilherme Andrade <[hidden email]> 于2019年5月27日周一 下午7:57写道:
Hello Monk Boy,

On Mon, 27 May 2019 at 12:51, Monk Boy <[hidden email]> wrote:
The openssl is installed, but why it is unusable?

Erlang/OTP 19 is not compatible with OpenSSL 1.1.x, unfortunately.

Related ticket in kerl repo:
https://github.com/kerl/kerl/issues/226

--
Guilherme

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu1804 install erlang with source: No usable OpenSSL found

Monk Boy
I have solved it with:

```
./configure --prefix=/home/memacs/opt/erlang/1903 --with-ssl=/home/memacs/opt/openssl/openssl-1.0.2r
```

Monk Boy <[hidden email]> 于2019年5月28日周二 上午9:51写道:
Ok, thanks.  I will update openssl to solve it.

Guilherme Andrade <[hidden email]> 于2019年5月27日周一 下午7:57写道:
Hello Monk Boy,

On Mon, 27 May 2019 at 12:51, Monk Boy <[hidden email]> wrote:
The openssl is installed, but why it is unusable?

Erlang/OTP 19 is not compatible with OpenSSL 1.1.x, unfortunately.

Related ticket in kerl repo:
https://github.com/kerl/kerl/issues/226

--
Guilherme

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions