utils/make_compiler_flags error

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

utils/make_compiler_flags error

Tuncer Ayaz-2
Does anybody else see the following error when building a fresh
otp.git master (98776a4) tree?

can't open x86_64-unknown-linux-gnu/opt/plain/erl_compile_flags.h for
writing at utils/make_compiler_flags line 65.

Reply | Threaded
Open this post in threaded view
|

[erlang-bugs] utils/make_compiler_flags error

Steve Vinoski
On Tue, Feb 25, 2014 at 2:38 PM, Tuncer Ayaz <tuncer.ayaz> wrote:

> Does anybody else see the following error when building a fresh
> otp.git master (98776a4) tree?
>
> can't open x86_64-unknown-linux-gnu/opt/plain/erl_compile_flags.h for
> writing at utils/make_compiler_flags line 65.
>

Yes.

--steve
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20140225/6f7cf954/attachment.html>

Reply | Threaded
Open this post in threaded view
|

[erlang-bugs] utils/make_compiler_flags error

Björn Gustavsson-3
In reply to this post by Tuncer Ayaz-2
On Tue, Feb 25, 2014 at 8:38 PM, Tuncer Ayaz <tuncer.ayaz> wrote:
> Does anybody else see the following error when building a fresh
> otp.git master (98776a4) tree?
>
> can't open x86_64-unknown-linux-gnu/opt/plain/erl_compile_flags.h for
> writing at utils/make_compiler_flags line 65.

Thanks for noticing this!

As far as I can tell, this annoying error message is harmless.
The script is executed everytime the Makefile is run, and the first
time the directories have not been created yet, so it fails. The second
time the Makefile is run (when doing the actual build), the script will
succeed silently.

It is too late for the rc2 release, but we will try to fix for the
final 17.0 release.

If anyone wants to fix it, patches are welcome.

/Bjorn

--
Bj?rn Gustavsson, Erlang/OTP, Ericsson AB

Reply | Threaded
Open this post in threaded view
|

[erlang-bugs] utils/make_compiler_flags error

Anthony Ramine-2
That bug was already reported and Lukas Larsson had written a fix:

        https://github.com/garazdawi/otp/tree/lukas/erts/make_deps_fixes

Regards,

--
Anthony Ramine

Le 26 f?vr. 2014 ? 12:36, Bj?rn Gustavsson <bjorn> a ?crit :

> On Tue, Feb 25, 2014 at 8:38 PM, Tuncer Ayaz <tuncer.ayaz> wrote:
>> Does anybody else see the following error when building a fresh
>> otp.git master (98776a4) tree?
>>
>> can't open x86_64-unknown-linux-gnu/opt/plain/erl_compile_flags.h for
>> writing at utils/make_compiler_flags line 65.
>
> Thanks for noticing this!
>
> As far as I can tell, this annoying error message is harmless.
> The script is executed everytime the Makefile is run, and the first
> time the directories have not been created yet, so it fails. The second
> time the Makefile is run (when doing the actual build), the script will
> succeed silently.
>
> It is too late for the rc2 release, but we will try to fix for the
> final 17.0 release.
>
> If anyone wants to fix it, patches are welcome.
>
> /Bjorn
>
> --
> Bj?rn Gustavsson, Erlang/OTP, Ericsson AB
> _______________________________________________
> erlang-bugs mailing list
> erlang-bugs
> http://erlang.org/mailman/listinfo/erlang-bugs