wxWidgets 3.1.2

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

wxWidgets 3.1.2

alex@xbasics.com
Has anyone encountered this same problem... the configuration for v21.2.6 doesn't seem to find the installation of the most recent version (3.1.2) of wxWidgets.  Although the README file under lib/wx identifies wxWidgets 2.8.* as target, version 3.0.* seem to have been working.

Thanks,
Alex


_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: wxWidgets 3.1.2

Wes James
On ubuntu I install what is available in the standard libs and it works.  libwxgtk3.0-dev.  In the past I've toyed with later versions (compile source), but erlang didn't seem to like it.  For awhile the working lib was 2.8, now it's 3.0.  

-wes

On Tue, Mar 5, 2019 at 12:09 PM [hidden email] <[hidden email]> wrote:
Has anyone encountered this same problem... the configuration for v21.2.6 doesn't seem to find the installation of the most recent version (3.1.2) of wxWidgets.  Although the README file under lib/wx identifies wxWidgets 2.8.* as target, version 3.0.* seem to have been working.

Thanks,
Alex

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: wxWidgets 3.1.2

alex@xbasics.com
Thanks for you feedback!  Really appreciate it.  Went back and realized that I didn't have the wxStyledTextControl enabled (--enable-stc) for the wxWidgets configuration, plus I could also enable compatibility with version 2.8.x, which doesn't hurt.  The configuration I ended up using, if it might help anyone out there is...

./configure --prefix=/usr --libdir=/usr/lib64 --sysconfdir=/etc --enable-mediactrl --with-opengl --enable-graphics_ctx --with-gtk=3 --enable-unicode --enable-compat28 --enable-plugins --enable-stc  --enable-shared --enable-stl --enable-webkit --enable-webview

After recompiling (and packaging) everything, things seem to be working fine now...

1> l(wx).
2> wx:new().
{wx_ref,0,wx,[]}

Thanks,
Alex


On 3/5/19 2:40 PM, Wes James wrote:
On ubuntu I install what is available in the standard libs and it works.  libwxgtk3.0-dev.  In the past I've toyed with later versions (compile source), but erlang didn't seem to like it.  For awhile the working lib was 2.8, now it's 3.0.  

-wes

On Tue, Mar 5, 2019 at 12:09 PM [hidden email] <[hidden email]> wrote:
Has anyone encountered this same problem... the configuration for v21.2.6 doesn't seem to find the installation of the most recent version (3.1.2) of wxWidgets.  Although the README file under lib/wx identifies wxWidgets 2.8.* as target, version 3.0.* seem to have been working.

Thanks,
Alex

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: wxWidgets 3.1.2

Dan Gudmundsson-2
wx still uses the 2.8-api so you need to explicit enable that in 3.1.2 with  --enable-compat28

On Tue, Mar 5, 2019 at 11:37 PM [hidden email] <[hidden email]> wrote:
Thanks for you feedback!  Really appreciate it.  Went back and realized that I didn't have the wxStyledTextControl enabled (--enable-stc) for the wxWidgets configuration, plus I could also enable compatibility with version 2.8.x, which doesn't hurt.  The configuration I ended up using, if it might help anyone out there is...

./configure --prefix=/usr --libdir=/usr/lib64 --sysconfdir=/etc --enable-mediactrl --with-opengl --enable-graphics_ctx --with-gtk=3 --enable-unicode --enable-compat28 --enable-plugins --enable-stc  --enable-shared --enable-stl --enable-webkit --enable-webview

After recompiling (and packaging) everything, things seem to be working fine now...

1> l(wx).
2> wx:new().
{wx_ref,0,wx,[]}

Thanks,
Alex


On 3/5/19 2:40 PM, Wes James wrote:
On ubuntu I install what is available in the standard libs and it works.  libwxgtk3.0-dev.  In the past I've toyed with later versions (compile source), but erlang didn't seem to like it.  For awhile the working lib was 2.8, now it's 3.0.  

-wes

On Tue, Mar 5, 2019 at 12:09 PM [hidden email] <[hidden email]> wrote:
Has anyone encountered this same problem... the configuration for v21.2.6 doesn't seem to find the installation of the most recent version (3.1.2) of wxWidgets.  Although the README file under lib/wx identifies wxWidgets 2.8.* as target, version 3.0.* seem to have been working.

Thanks,
Alex

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
Reply | Threaded
Open this post in threaded view
|

Re: wxWidgets 3.1.2

alex@xbasics.com
I imagined that to be the case, but thanks for clearing that out!

Cheers,
Alex


On 3/6/19 1:51 AM, Dan Gudmundsson wrote:
wx still uses the 2.8-api so you need to explicit enable that in 3.1.2 with  --enable-compat28

On Tue, Mar 5, 2019 at 11:37 PM [hidden email] <[hidden email]> wrote:
Thanks for you feedback!  Really appreciate it.  Went back and realized that I didn't have the wxStyledTextControl enabled (--enable-stc) for the wxWidgets configuration, plus I could also enable compatibility with version 2.8.x, which doesn't hurt.  The configuration I ended up using, if it might help anyone out there is...

./configure --prefix=/usr --libdir=/usr/lib64 --sysconfdir=/etc --enable-mediactrl --with-opengl --enable-graphics_ctx --with-gtk=3 --enable-unicode --enable-compat28 --enable-plugins --enable-stc  --enable-shared --enable-stl --enable-webkit --enable-webview

After recompiling (and packaging) everything, things seem to be working fine now...

1> l(wx).
2> wx:new().
{wx_ref,0,wx,[]}

Thanks,
Alex


On 3/5/19 2:40 PM, Wes James wrote:
On ubuntu I install what is available in the standard libs and it works.  libwxgtk3.0-dev.  In the past I've toyed with later versions (compile source), but erlang didn't seem to like it.  For awhile the working lib was 2.8, now it's 3.0.  

-wes

On Tue, Mar 5, 2019 at 12:09 PM [hidden email] <[hidden email]> wrote:
Has anyone encountered this same problem... the configuration for v21.2.6 doesn't seem to find the installation of the most recent version (3.1.2) of wxWidgets.  Although the README file under lib/wx identifies wxWidgets 2.8.* as target, version 3.0.* seem to have been working.

Thanks,
Alex

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions
_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions

_______________________________________________
erlang-questions mailing list
[hidden email]
http://erlang.org/mailman/listinfo/erlang-questions